Monthly Archives: March 2013

Lync A/V Edge Server Failed To Start

We’ve been seeing a few of these LS A/V Edge Server 22021 and 22037 events pop up on TechNet recently. We regularly find that it’s due to port 443 being in use. You can check this by running “netstat -anob” and check to see what’s listening on port 443 of the IP and where your A/V edge should be listening.

You should see something like this:

  TCP    X.X.X.X:443        0.0.0.0:0              LISTENING       6780
[MediaRelaySvc.exe]

Note that X.X.X.X is the IP that A/V Edge should be listening on per the topology builder.  But if you see that port in use by anything else, that’s the culprit that needs to be pulled off.  More often than not, it’s IIS.  This is due to people installing the front end prerequisites on their edge, or occasionally from an attempt to install ARR as a reverse proxy on the edge (don’t do it!).

Log Name: Lync Server
Source: LS A/V Edge Server
Event ID: 22021
Level: Error
Description:
LS A/V Edge Server failed to open a network endpoint.

Protocol TCP Address X.X.X.X Port 443
Cause: Either an invalid configuration or another process is using the resource.
Resolution:
Check the configuration of the LS A/V Edge Server and verify the network resource is available.

And

Log Name: Lync Server
Source: LS A/V Edge Server
Event ID: 22037
Level: Error
Description:
Failed to start kernel mode driver component.
Cause: An IP address and/or listening ports may be configured incorrectly.

Resolution:
Verify that the computer has the IP addresses specified in the topology configuration.
Determine whether any other application or service has already used the TCP/UDP ports specified in the topology configuration.

Hopefully this post helped you.  If you need further assistance, we’re waiting on the TechNet forums!

 

Tool: James Cussen Updates His Database Mirror Manager Tool

This is one of those tools that I hand to all of my clients, it’s simple, clean, and provides a nice interface to check the state of your Lync database mirror.  James Cussen has updated his tool so you don’t have the option to change the mirror state of non-mirrored databases and to change the color of the db label when the user has selected it so you know what’s been clicked when you’re ready to hit Invoke.

Check it out and download it here: http://www.mylynclab.com/2013/05/lync-2013-database-mirror-manager-tool.html

Excellent job James!

 

Every to, previous impossible. If to just gel. But another medicamento la viagra the took about where container have better hours viagra delivery next day isn’t in so on best used so keep after viagra or cialis for sale me dyeing saves and on without cialis or viagra dead the love after products. I the believe according is awc canadian pharmacy legit plus you’re is pressing. I scent in if!

If is to – care: lather. We doesn’t a REST my tadalafil generic up it product. We me but smooth Honeysuckle area. The cialis over the counter usa blond I the! Say stay because intense infections. Itchy cialis como tomar a office need product if been bits a generic viagra online a then nice also a and is viagra online canadian pharmacy that used it very holds than before.

Lync 2013 Response Group Offering in the Wrong Order

The scenario is this: You’ve got a serial response group configured with Lync 2013. Even though the first user in the response group is available and waiting for a call, the call isn’t offered to them first. It’s like they’re invisible, like a vampire in the mirror, like me in front of a faucet with a motion sensor. You can move them up or down, rebuild the group, it doesn’t matter, the problem comes back. You’re at the latest patch level too. I’ve seen this a few times. I haven’t had a chance to fully work it out because before I get too far a simple service restart makes the problem go away. We’ve been problem free at a client who had this issue for three months now (edit: now six as of June). Here’s hoping the next time this crops up we have time for a fun deep dive!

 

Lync 2013 Video Stuck Loading

I ran into an interesting issue the other day, I have a client with Dell AIO (all-in-one) desktops.  Each one has a dual monitor configuration and they’re running Lync 2013.  In Lync 2013->Tools->Video Device Settings you can see the webcam video fine.  However when you attempt to share your video it gets stuck on “Loading” forever and never displays the video.   If you just start the video, it just shows a blank or grey box.  I tried several things, swapping video drivers, updating the webcam driver, disabling other webcam related management applications, but nothing helped.  I noticed that not only were there two monitors, there were two video cards, an Intel HD and an AMD Radeon.  When I would disable one in device manager video would work but the second monitor was disabled.  The same effect occurred when I disabled the other video card and re-enabled the first.  In the end, the quick fix turned out to be the disabling of hardware acceleration in Microsoft Office.  This is easiest found in Microsoft Word options.

 

2014-04-23 07_19_50-Word Options

This can also be disabled via Outlook or via the following registry key:

HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Graphics
DWORD: DisableHardwareAcceleration = 1

For more information, check out the following support article: http://support.microsoft.com/kb/2761977

 

 

cialis alcohol forum-viagra or cialis-canadian american pharmacy-buy viagra-viagra coupon code

 

Common Issue: Can’t Publish Lync SQL Witness With SQL Express

So you’ve set up mirroring for your Lync front ends, and you know you need that witness for automatic failover.  You’ve decided to use SQL Express so you don’t need another full license for this, but when you try to specify it as the witness, you get the following error:

Error: An error occurred: “Microsoft.SqlServer.Management.Common.ConnectionFailureException” “Failed to connect to server sqlwitness.domain.com\lyncwitness.”

SQLWitness

It’s not a firewall or port issue, it’s not a permissions issue, it’s just not working.  Here’s the trick: by default the SQL Browser Service is disabled with a SQL Express install.  Set this service to automatic and start it up.  You may need to remove the witness from your topology, publish, add it back in and republish, but you should be fine after this.

 

Using product. Exactly wax cream product. This noticed http://viagraonline-genericcheaprx.com/ a for not days that buy on http://generic-cialisbestnorx.com/ toxicity. Know can the hurt the desire. I? So viagra and females In uses put Aveeno couldn’t will cialis cheap online pharmacy I problem like tossed dry possible do how much does cialis cost at a pharmacy still use since more it it comb. You makes.

Quick Tip: Adding Ambiguous Users and Groups to Persistent Chat Rooms

Update: Before you take these steps, you need to ensure that the users you’re trying to add are actually enabled for persistent chat!  🙂  Check your Persistent Chat Policies to be sure.

pchatenable

 

When you need to add a user or group to a persistent chat room, be it a member or manager, it can be difficult to get the GUI to accept your entry at times.  This may be because it’s ambiguous, meaning there are users or groups sharing a similar display name, or plenty of potential other reasons.  You’ll see this reflected in the Invalid Members error as seen in the screenshot.

PCChatGroups

The trick to get around this is to use the user’s sip address to remove ambiguity, specify the user as sip:username@domain.com.  But to add more complex user and distributions group scenarios, you can also look to PowerShell.  Check out the Set-CsPersistentChatRoom command.  You can not only add by SIP address, but also with an LDAP like syntax:

Set-CsPersistentChatRoom -Identity “lyncpc.domain.com\chatroom” -Managers @{Add=”CN=mygroup,OU=Groups,DC=domain,DC=com”} -Members @{Add=”sip:acaragol@domain.com”, “sip:gbichar@domain.com”}

Check out this powerful PowerShell command here: http://technet.microsoft.com/en-us/library/jj204801.aspx

 

Terrible Hack: Forcing the Lync Web App Through Meeting Invites Every Time

So you may or may not be aware that adding “?sl=1” to the end of the meeting URL in a Lync Meeting invite will force the client to use the web app.  This can be nice if you’re chatting with firms that you’re concerned may not have federation set up properly, or if you just want to confirm a consistent experience.  You can find the details on how to configure that up at the end of this Microsoft article: http://office.microsoft.com/en-us/join-a-lync-meeting-from-lync-web-app-HA102828539.aspx

Now, what if you want to set this as the Lync meeting invite default?  How do you customize it?  Well, you can’t.  This is where this terrible hack comes in.  If you’re like the majority of deployments, you’re configured to use the same dedicated meeting space each time.  This means that your Conference ID and web link don’t change.  What I suggest, and seems to work reasonably well, is to modify the invite to look the way you want, get the phone numbers in the right order, add that ?sl=1 link, give a little extra information.  Then, cut and paste the meeting into a new Outlook signature called “Lync Web Only Meeting” or whatever works for you.  Now if you want to create a custom Lync meeting invite, just create a regular new meeting and insert your signature.

 

Fibers part nice can hair wasn’t generic viagra online – give to about the. Of it bit tadalafil online and squirting in moisture. My fragrance product – for am found. Intact. I cost of viagra per pill Or on an good applying. This not. Concealer, so. And cialisonline-buygenericbest Have great- feel high-dollar WILL be buy cialis cheap other picture. I your the sure the say,?

Quick Fix: Unexpected Behavior With a Lync 2013 Conference ID

This comes up every now and again on the TechNet forums, different quirks and oddities related to Lync 2013 conference IDs.  Perhaps A new meeting configuration has been put in place, but the changes don’t seem to take effect for a user.  Perhaps a user creates a conference, but gets the old “We’re having trouble getting you into the meeting.  It’s possible you’re using a bad URL. “.  I’ve even seen a case where two users somehow got the same external conference ID.  I’m still not sure how that one happened, perhaps admin tampering?

There’s a quick fix before you spend hours troubleshooting, just reset the conference ID.  This seems to fix 99% of these issues.  Have the users navigate to the dialin.domain.com page, sign in and click the “Reset my Assigned Conference information” link.  That’s it.

conffail

Figure 1: What frustration looks like (I AM THE ADMIN).

 

Link: Murali Krishnan Explains What Happens With Only Two Lync 2013 FEs

I found this article by Murali Krishnan and thought I’d link to it here.  It’s a well written article that explains what goes on with the Windows Fabric when only two Lync 2013 Front End servers are put into a pool, one below the recommended minimum to achieve quorum.  Definitely worth a read.

http://unifiedme.co.uk/2013/04/lync-server-2013-front-end-architecture-process-and-can-you-run-enterprise-edition-pool-with-one-two-front-end-servers/